Degraded dashboard and checkout experience due to DDoS attack

Incident Report for ThriveCart

Resolved

Degraded dashboard and checkout experience was due to a DDoS attack which we have resolved now.
Posted Mar 26, 2026 - 16:10 UTC

Update

We are continuing to investigate this issue.
Posted Mar 26, 2026 - 16:05 UTC

Investigating

We are busy investigating, more details to follow shortly.
Posted Mar 26, 2026 - 15:44 UTC
This incident affected: Account Dashboard and Checkouts and Payment Processing.