Service Disruption - Checkout & Login Unavailable

Incident Report for ThriveCart

Resolved

All systems are now operational. You may experience degraded performance in the next 15 minutes maximum as the system is backfilling data.

We apologise for the disruption and appreciate your patience.
Posted Jul 03, 2026 - 18:29 UTC

Update

We are still continuing to monitor the situation. Our checkout service remains unavailable while we wait for the database backup/restore process to complete.

Current status: Upgrade still in progress

We appreciate your patience and will post another update as soon as the backup finishes and we begin restoring service. We apologize for the extended downtime.
Posted Jul 03, 2026 - 13:46 UTC

Update

We are continuing to monitor the situation. Our checkout service remains unavailable while we wait for the database backup/restore process to complete.

Current status: Upgrade still in progress

We appreciate your patience and will post another update as soon as the backup finishes and we begin restoring service. We apologize for the extended downtime.
Posted Jul 03, 2026 - 12:29 UTC

Monitoring

We have received confirmation from AWS Support regarding the cause and estimated resolution of this incident.

Root cause confirmed: AWS performed an automatic mandatory upgrade of our primary production database.

Estimated resolution: AWS estimates the total upgrade duration to be approximately 3 hours from the start time of 08:42 UTC, placing the projected completion at ~11:43 UTC. Please note this is an estimate and actual completion may vary.

What to expect: Once the upgrade completes, the database will become available automatically and normal service will resume. Our team will confirm and update this page immediately.

We apologise for the disruption and appreciate your patience.
Posted Jul 03, 2026 - 11:01 UTC

Investigating

We have received confirmation from AWS Support regarding the cause and estimated resolution of this incident.

Root cause confirmed: AWS performed an automatic mandatory upgrade of our primary production database.

Estimated resolution: AWS estimates the total upgrade duration to be approximately 3 hours from the start time of 08:42 UTC, placing the projected completion at ~11:43 UTC. Please note this is an estimate and actual completion may vary.

What to expect: Once the upgrade completes, the database will become available automatically and normal service will resume. Our team will confirm and update this page immediately.

We apologise for the disruption and appreciate your patience.
Posted Jul 03, 2026 - 11:00 UTC

Monitoring

Awaiting confirmation from AWS that the database upgrade has completed
Posted Jul 03, 2026 - 09:45 UTC

Identified

ThriveCart experienced a service disruption affecting checkout and user login. Customers and vendors encountered 504 Gateway Timeout errors and were unable to access the platform.

Root cause

The outage was triggered by an unscheduled database upgrade performed by AWS on our primary production database, upgrading MariaDB minor version. This upgrade occurred without prior notification and despite auto minor version upgrades being disabled on the instance.

The database upgrade requires downtime and does not provide a progress indicator, limiting our ability to give a precise recovery ETA.
Posted Jul 03, 2026 - 08:45 UTC
This incident affected: Thrivecart (Webhooks, Integrations & API, Checkouts & Payment Processing).