Degraded Service

Incident Report for ThriveCart

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 09:36 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 07:59 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 07:41 UTC

Identified

Affects: ThriveCart Dashboard

Symptoms:
At 06:51 GMT+1, we were notified of an incident with Amazon AWS servers on the East Coast of the U.S.

Next Steps:
We are closely monitoring the situation and will keep you informed as AWS resolve their issues.
You can also follow their updates here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 07:36 UTC
This incident affected: API, Account Dashboard, Checkouts and Payment Processing, Sales Pages, and Learn.